Email delays
Incident Report for Onehub
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 14:40 PDT
Monitoring
We identified an issue affecting outgoing email delivery causing delays starting around 9 PM UTC on 6/1/2021. We've fixed the issue that caused the delays and are now working through a backlog of delayed deliveries.
Posted Jun 02, 2021 - 13:06 PDT
This incident affected: Outgoing Email.